free web page hit counter
Thursday, April 18, 2024
Advertisment
HomeGeneralAndroid 15 may raise minimum requirement for apps and block outdated apps:...

Android 15 may raise minimum requirement for apps and block outdated apps: report

- Advertisement -

Android 15 may raise minimum requirement for apps and block outdated apps: report

- Advertisement -

Android 15 May block some apps that are currently running. Google Play Store or available in third-party marketplaces, according to a report. Google is rumored to bring the next generation of its operating system to Android devices in the latter half of 2024. release On March 21, Android 15 Developer Preview 2 showcased several new features. Now, a report suggests that Google may raise the minimum requirement for apps with an upcoming OS update.

Oh Reports It was highlighted by Android Police that the Software Development Kit (SDK) requirement was changed and now supports higher versions. With every new OS update, Google Adds new features and security parameters to the Android ecosystem. However, this gives developers enough time to meet the latest requirements. For example, currently, on Android 14, developers are asked to target Android 6.0 or Marshmallow, which was released in 2015.

This OS was important because it required apps to obtain separate consent from users for sensitive permissions such as access to the camera, address book, call logs and more. But now, the report finds that Android 15 The DP2 build is not allowing apps that target the Android 6.0-based SDK 23 to be installed on devices. Instead, it is now asking for SDK version 24 which is Android 7.1.

Running a test trying to install an app that hadn’t been brought up to SDK 24, the report found that a smartphone running Android 14 was able to install and run it easily. However, when tested on Android 15 DP2-powered. Google Pixel 8 Pro, an error appeared that said “INSTALL_FAILED_DEPRECATED_SDK_VERSION”. Even when trying to sideload the app, the OS popped up a message saying it was unsafe to install the app.

The message is not new and sideloading apps usually prompt this alert. However, the surprising thing was that Install anyway. The button that appears later did nothing and the app failed to install. Based on the results, it appears that apps that are still targeting Android 6.0 will likely stop working once Android 15 is released globally. However, it has been noted that many apps today do not target SDK 23 as developers try to upgrade app versions to the latest Android standard.


Affiliate links may be generated automatically – see our Statement of Ethics For details

For More Detail www.gadgets360.com

Minimum requirement of android 15 apps old blocked report increased to android 15.,Android,Google,Features of Android 15

- Advertisement -
RELATED ARTICLES
- Advertisment -

Most Popular

- Advertisment -

Recent Comments